Hello all —

I am trying to install FSL 6.0.1 and am running into some problems. We are using ubuntu 14.04 LTS with python 2.7.6.

I seem to be unable to install the im* commands (imcp, immv, imglob).  I have tried advice to remove the fslpython directory and reinstall using fslpython_install.sh.

The installer seems to run through correctly, with stage 2 taking several minutes.  Upon completion there are no error messages, and there is no log file within /tmp.

I can see that the soft links for the im* commands exist in the fsl bin directory:

cbt-imaging@CBT-Imaging:/usr/local/fsl-6$ ll /usr/local/fsl-6/bin/imcp
lrwxrwxrwx 1 root root 50 Jun 12 11:42 /usr/local/fsl-6/bin/imcp -> /usr/local/fsl-6/fslpython/envs/fslpython/bin/imcp
 
However, the commands do not appear to exist within fslpython/bin:
cbt-imaging@CBT-Imaging:/usr/local/fsl-6$ ls /usr/local/fsl-6/fslpython/envs/fslpython/bin/i*
/usr/local/fsl-6/fslpython/envs/fslpython/bin/icu-config  
/usr/local/fsl-6/fslpython/envs/fslpython/bin/icuinfo     
/usr/local/fsl-6/fslpython/envs/fslpython/bin/idle3       
/usr/local/fsl-6/fslpython/envs/fslpython/bin/idle3.5     
/usr/local/fsl-6/fslpython/envs/fslpython/bin/ipython     
/usr/local/fsl-6/fslpython/envs/fslpython/bin/ipython3

I modifed fslpython_install.sh so it would not delete the log file at the end, deleted the fslpython directory, and reran the installer.  I reviewed the log file and cannot find any errors, only a warning regarding pip not being listed as a conda dependency.

Are there any other suggestions as to how to resolve this?

Thank you —
Amanda




To unsubscribe from the FSL list, click the following link:
https://www.jiscmail.ac.uk/cgi-bin/webadmin?SUBED1=FSL&A=1