Print

Print


Thank you so much for the reply Mark. I finally got the install working but am having issues with SGE that I believe are in regards to the setup. I have the data on a separate partition/drive from the operating system on the head node. I have 3 compute nodes each with a single hard drive for their operating system. When I run FEAT, I keep getting the error “Cannot chdir to <path to data>” where path to data points to the data disk. I explored a little, and when I ssh’d into the compute nodes, I also got the error “Cannot chdir to <path to home directory>” where path to home is /export/home/username. This was fixed by editing the /etc/exports file to add a line for each /export for each compute node. I then thought my issue might be fixed if I change the mount point of the data to /export/somewhere, however this did not fix it. This is as far as I got.

 

My next steps are to:

 

  1. Shutdown the compute nodes and attempt to run SGE (thinking the issue is just with the mapping of the data disk to the compute nodes)
  2. Move data disk to /media -> I noticed some things are setup by default in Centos 6.6 by the mount point
  3. Try starting and mounting a samba share on each compute node with the same hierarchy as the head node
  4. Run in circles

 

Matthew Sherwood

Director, Research Engineer

Neuro Modulation and Physiology Laboratory

 

Wright State University

Neuroscience Engineering Collaboration 414

3640 Colonel Glenn Hwy

Dayton, OH 45435

 

Cell: 937.524.3924

E-Mail: [log in to unmask]

 

From: FSL - FMRIB's Software Library [mailto:[log in to unmask]] On Behalf Of Mark Jenkinson
Sent: Saturday, August 5, 2017 06:10
To: [log in to unmask]
Subject: Re: [FSL] setup on a rocks cluster

 

Hi,

 

I don't know of anyone having done this - but if there is anyone, then please do reply!

 

In general you can edit fsl_sub (which is a reasonably simple script) and replace the SGE syntax with equivalent ones for other clusters.  Depending on how things work that might be difficult in some cases though.

 

Is there anything in specific that we could help with?

We don't know of a setup on a rocks cluster, but still might be able to help with something if you send us some details.

 

Cheers,

MJ

 

 

 

On 2 Aug 2017, at 20:56, Sherwood, Matt <[log in to unmask]> wrote:

 

Dear FSL users,

              

I was wondering if anyone has successfully setup FSL on a rocks cluster? I am having a few issues regarding shell setup following running the installer and SGE/condor initialization.

 

Thanks,

 

Matthew Sherwood

Director, Research Engineer

Neuro Modulation and Physiology Laboratory

 

Wright State University

Neuroscience Engineering Collaboration 414

3640 Colonel Glenn Hwy

Dayton, OH 45435

 

Cell: 937.524.3924