Hello,
 
Thanks a lot for both of your answers. The problem was fixed. But now when I reached to the second step, create PPI variable, SPM showed another error,
 
Warning: Matrix is close to singular or badly scaled.
         Results may be inaccurate. RCOND = 1.266417e-020.
> In spm_PEB>spm_inv at 371
  In spm_PEB at 244
  In spm_peb_ppi at 325
 
Does this mean that my design is not good enough to conduct PPI analysis?
 
Thanks!
 
Ning

From: MCLAREN, Donald
Sent: Friday, March 04, 2011 4:09 PM
To: [log in to unmask]
Subject: Re: [SPM] PPI problem

Ning,

(1) You can only adjust when you have an F-test;
(2) Did you move the input images (or SPM.mat file) after doing the first level model (e.g. SPM.xY.VY.fname no longer points to the correct locations of the files)?

Best Regards, Donald McLaren
=================
D.G. McLaren, Ph.D.
Postdoctoral Research Fellow, GRECC, Bedford VA
Research Fellow, Department of Neurology, Massachusetts General Hospital and Harvard Medical School
Office: (773) 406-2464
=====================
This e-mail contains CONFIDENTIAL INFORMATION which may contain PROTECTED HEALTHCARE INFORMATION and may also be LEGALLY PRIVILEGED and which is intended only for the use of the individual or entity named above. If the reader of the e-mail is not the intended recipient or the employee or agent responsible for delivering it to the intended recipient, you are hereby notified that you are in possession of confidential and privileged information. Any unauthorized use, disclosure, copying or the taking of any action in reliance on the contents of this information is strictly prohibited and may be unlawful. If you have received this e-mail unintentionally, please immediately notify the sender via telephone at (773) 406-2464 or email.

 
From: [log in to unmask] href="">junhai xu
Sent: Friday, March 04, 2011 11:23 AM
To: Ning Ma
Subject: Re: [SPM] PPI problem

I got the same problem when I analyzed our data. Maybe you moved your original data or changed the path of your data.
You can load the SPM.mat, and find the right path.

Best,
Junhai

2011/3/4 Ning Ma <[log in to unmask]>
 
Dear SPM users,
 
Recently, I started to use SPM5 to conducted PPI analysis and encountered a problem.
 
After selected the SPM.mat from single subject data, I went to ROI and right click to get Local Max. And then I pressed 'eigenvariate' and name the VOI. After inputting VOI name, SPM skipped the step of adjust data, directly jump to VOI definition step. After inputting the radius of the VOI, SPM reported the error as
 
spm_mip_ui: Jumped 6.00mm from [  0,  60,  10],
   to nearest local maxima at [ -4,  62,  14]
??? Cant open image file.
 
Error in ==> spm_get_data at 41
 Y(i,:) = spm_sample_vol(V(i),XYZ(1,:),XYZ(2,:),XYZ(3,:),0);
 
Error in ==> spm_regions at 182
y        = spm_get_data(SPM.xY.VY,xSPM.XYZ(:,Q));
 
??? Error while evaluating uicontrol Callback.
 
How to fix this problem? Thanks a lot in advance!
 
Best Regards,
Ning Ma