JiscMail Logo
Email discussion lists for the UK Education and Research communities

Help for FSL Archives


FSL Archives

FSL Archives


FSL@JISCMAIL.AC.UK


View:

Message:

[

First

|

Previous

|

Next

|

Last

]

By Topic:

[

First

|

Previous

|

Next

|

Last

]

By Author:

[

First

|

Previous

|

Next

|

Last

]

Font:

Proportional Font

LISTSERV Archives

LISTSERV Archives

FSL Home

FSL Home

FSL  June 2019

FSL June 2019

Options

Subscribe or Unsubscribe

Subscribe or Unsubscribe

Log In

Log In

Get Password

Get Password

Subject:

Re: Issue with FSL 5.0.11

From:

"West, John D." <[log in to unmask]>

Reply-To:

FSL - FMRIB's Software Library <[log in to unmask]>

Date:

Thu, 20 Jun 2019 17:58:28 +0000

Content-Type:

text/plain

Parts/Attachments:

Parts/Attachments

text/plain (1 lines)

Hi.



I ran into the deprecation errors as below so was trying to follow this, but I am having the same issue as Tim in that the new yml file doesn't generate those executables (immv, imglob, imcp).  The links are there is $FSLDIR/bin but the $FSLDIR/fslpython/envs folder is completely empty except for a .conda_envs_dir_test file which is a blank file.



Any suggestions?



Thanks.

-John



-----Original Message-----

From: FSL - FMRIB's Software Library <[log in to unmask]> On Behalf Of paul mccarthy

Sent: Tuesday, May 7, 2019 8:30 AM

To: [log in to unmask]

Subject: Re: [FSL] Issue with FSL 5.0.11



Hi Tim,



Do imglob, immv, imcp, etc exist in this directory?



$FSLDIR/fslpython/envs/fslpython/bin/



If so, it just means that the symlinks to them weren't created - this may happen if you used "sudo" to run the fslpython_install.sh script, as the final symlink-creation stage may not have been able to find $FSLDIR.



The easiest thing to do at this stage is probably just to manually create them, like so (you may need sudo):



ln -s $FSLDIR/fslpython/envs/fslpython/bin/imcp $FSLDIR/bin/imcp ln -s $FSLDIR/fslpython/envs/fslpython/bin/imglob $FSLDIR/bin/imglob ln -s $FSLDIR/fslpython/envs/fslpython/bin/immv $FSLDIR/bin/immv ln -s $FSLDIR/fslpython/envs/fslpython/bin/atlasq $FSLDIR/bin/atlasq ln -s $FSLDIR/fslpython/envs/fslpython/bin/atlasquery $FSLDIR/bin/atlasquery ln -s $FSLDIR/fslpython/envs/fslpython/bin/fsl_ents $FSLDIR/bin/fsl_ents



Cheers,



Paul



On 03/05/2019, Timothy Hendrickson <[log in to unmask]> wrote:

> Paul,

>

> The versioning errors have disappeared, but it appears that imglob, 

> immv, and imcp are not generating. I've attempted to follow the 

> instructions

> here: https://fsl.fmrib.ox.ac.uk/fsl/fslwiki/FslInstallation. but that 

> does not make a difference. Could it be due to the yml file?

>

> Best,

>

> -Tim

>

>

> On Thu, Apr 25, 2019 at 4:07 PM paul mccarthy 

> <[log in to unmask]>

> wrote:

>

>> Hi Tim,

>>

>> After further exploration, I've realised that I wasn't quite correct 

>> in my initial diagnosis. But this is due to a change in behaviour 

>> between the different versions of conda, and the 

>> fslpython_environment.yml file that I provided should still work - 

>> let me know if it doesn't.

>>

>> Cheers,

>>

>> Paul

>>

>> On 25/04/2019, Timothy Hendrickson <[log in to unmask]> wrote:

>> > Ah thank you so much Paul! You have likely saved me many hours of 

>> > troubleshooting.

>> >

>> > Best,

>> >

>> > -Tim

>> >

>> >

>> > On Thu, Apr 25, 2019 at 3:42 PM paul mccarthy 

>> > <[log in to unmask]>

>> > wrote:

>> >

>> >> Hi Tim,

>> >>

>> >> I've managed to reproduce this problem - it appears to be due to a 

>> >> change in the way that conda is creating the internal FSL python 

>> >> environment. The version of conda that was available when FSL 

>> >> 5.0.11 was released would install all dependencies of our 

>> >> libraries without us having to explicitly list them. However, the 

>> >> latest version of conda only installs the libraries that we list, 

>> >> and does not install any of their dependencies.

>> >>

>> >> So your fslpython environment is incomplete. As an interim 

>> >> workaround until we can fix this, after fslinstaller.py has run:

>> >>

>> >>  1. Make sure that $FSLDIR is set to the directory that you just 

>> >> installed FSL to

>> >>

>> >>  2. take the attached fslpython_environment.yml file and copy it 

>> >> into $FSLDIR/etc/fslconf/ (overriding the file that is already there).

>> >>

>> >>  3. Run $FSLDIR/etc/fslconf/fslpython_install.sh

>> >>

>> >> Cheers,

>> >>

>> >> Paul

>> >>

>> >> On 25/04/2019, Timothy Hendrickson <[log in to unmask]> wrote:

>> >> > Hmm, that does not make a lot of sense. Even though I said that 

>> >> > I was attempting to redownload FSL what I am really doing is 

>> >> > using FSL

>> within

>> >> > a

>> >> > container so I am not redownloading FSL.

>> >> >

>> >> > Has something fundamentally changed about fslinstaller.py within 

>> >> > the last few weeks that could be resulting in this error?

>> >> >

>> >> > Best,

>> >> >

>> >> > -Tim

>> >> >

>> >> >

>> >> >

>> >> > On Tue, Apr 23, 2019 at 4:21 PM paul mccarthy <

>> [log in to unmask]>

>> >> > wrote:

>> >> >

>> >> >> Hi Timothy,

>> >> >>

>> >> >> I'm guessing that you overwrote the old FSL installation with 

>> >> >> the new one, and that this has somehow caused the internal 

>> >> >> fslpython environment to become corrupted.

>> >> >>

>> >> >> Follow the instructions here to re-install fslpython:

>> >> >>

>> >> >>

>> >> >>

>> >>

>> https://fsl.fmrib.ox.ac.uk/fsl/fslwiki/FslInstallation#imcp.2Fimglob.

>> 2Fimmv_errors_after_installation

>> >> >>

>> >> >> Cheers,

>> >> >>

>> >> >> Paul

>> >> >>

>> >> >> On 23/04/2019, Timothy Hendrickson <[log in to unmask]> wrote:

>> >> >> > Hello,

>> >> >> >

>> >> >> > I recently have been using FSL 5.0.11 without issue. I ended 

>> >> >> > up having to redownload FSL and now get the following 

>> >> >> > traceback.  Any thoughts?

>> >> >> >

>> >> >> > Here is the traceback:

>> >> >> >

>> >> >> > Traceback (most recent call last):

>> >> >> >

>> >> >> >   File

>> >> >> >

>> >> >>

>> >>

>> "/usr/local/fsl/fslpython/envs/fslpython/lib/python3.6/site-packages/

>> pkg_resources/__init__.py",

>> >> >> > line 583, in _build_master

>> >> >> >

>> >> >> >     ws.require(__requires__)

>> >> >> >

>> >> >> >   File

>> >> >> >

>> >> >>

>> >>

>> "/usr/local/fsl/fslpython/envs/fslpython/lib/python3.6/site-packages/

>> pkg_resources/__init__.py",

>> >> >> > line 900, in require

>> >> >> >

>> >> >> >     needed = self.resolve(parse_requirements(requirements))

>> >> >> >

>> >> >> >   File

>> >> >> >

>> >> >>

>> >>

>> "/usr/local/fsl/fslpython/envs/fslpython/lib/python3.6/site-packages/

>> pkg_resources/__init__.py",

>> >> >> > line 791, in resolve

>> >> >> >

>> >> >> >     raise VersionConflict(dist, 

>> >> >> > req).with_context(dependent_req)

>> >> >> >

>> >> >> > pkg_resources.ContextualVersionConflict: (deprecation 2.0

>> >> >> >

>> (/usr/local/fsl/fslpython/envs/fslpython/lib/python3.6/site-packages)

>> ,

>> >> >> > Requirement.parse('deprecation<=2.*,>=1.*'), {'fslpy'})

>> >> >> >

>> >> >> >

>> >> >> >

>> >> >> > During handling of the above exception, another exception

>> >> >> > occurred:

>> >> >> >

>> >> >> > Traceback (most recent call last):

>> >> >> >

>> >> >> >   File "/usr/local/fsl/bin/imglob", line 6, in <module>

>> >> >> >

>> >> >> >     from pkg_resources import load_entry_point

>> >> >> >

>> >> >> >   File

>> >> >> >

>> >> >>

>> >>

>> "/usr/local/fsl/fslpython/envs/fslpython/lib/python3.6/site-packages/

>> pkg_resources/__init__.py",

>> >> >> > line 3241, in <module>

>> >> >> >

>> >> >> >     @_call_aside

>> >> >> >

>> >> >> >   File

>> >> >> >

>> >> >>

>> >>

>> "/usr/local/fsl/fslpython/envs/fslpython/lib/python3.6/site-packages/

>> pkg_resources/__init__.py",

>> >> >> > line 3225, in _call_aside

>> >> >> >

>> >> >> >     f(*args, **kwargs)

>> >> >> >

>> >> >> >   File

>> >> >> >

>> >> >>

>> >>

>> "/usr/local/fsl/fslpython/envs/fslpython/lib/python3.6/site-packages/

>> pkg_resources/__init__.py",

>> >> >> > line 3254, in _initialize_master_working_set

>> >> >> >

>> >> >> >     working_set = WorkingSet._build_master()

>> >> >> >

>> >> >> >   File

>> >> >> >

>> >> >>

>> >>

>> "/usr/local/fsl/fslpython/envs/fslpython/lib/python3.6/site-packages/

>> pkg_resources/__init__.py",

>> >> >> > line 585, in _build_master

>> >> >> >

>> >> >> >     return cls._build_from_requirements(__requires__)

>> >> >> >

>> >> >> >   File

>> >> >> >

>> >> >>

>> >>

>> "/usr/local/fsl/fslpython/envs/fslpython/lib/python3.6/site-packages/

>> pkg_resources/__init__.py",

>> >> >> > line 598, in _build_from_requirements

>> >> >> >

>> >> >> >     dists = ws.resolve(reqs, Environment())

>> >> >> >

>> >> >> >   File

>> >> >> >

>> >> >>

>> >>

>> "/usr/local/fsl/fslpython/envs/fslpython/lib/python3.6/site-packages/

>> pkg_resources/__init__.py",

>> >> >> > line 786, in resolve

>> >> >> >

>> >> >> >     raise DistributionNotFound(req, requirers)

>> >> >> >

>> >> >> > pkg_resources.DistributionNotFound: The 'deprecation<=2.*,>=1.*'

>> >> >> > distribution was not found and is required by fslpy

>> >> >> >

>> >> >> > Best,

>> >> >> >

>> >> >> > -Tim

>> >> >> >

>> >> >> >

>> >> ##################################################################

>> >> ######

>> >> >> >

>> >> >> > To unsubscribe from the FSL list, click the following link:

>> >> >> > https://www.jiscmail.ac.uk/cgi-bin/webadmin?SUBED1=FSL&A=1

>> >> >> >

>> >> >>

>> >> >>

>> #####################################################################

>> ###

>> >> >>

>> >> >> To unsubscribe from the FSL list, click the following link:

>> >> >> https://www.jiscmail.ac.uk/cgi-bin/webadmin?SUBED1=FSL&A=1

>> >> >>

>> >> >

>> >> >

>> #####################################################################

>> ###

>> >> >

>> >> > To unsubscribe from the FSL list, click the following link:

>> >> > https://www.jiscmail.ac.uk/cgi-bin/webadmin?SUBED1=FSL&A=1

>> >> >

>> >>

>> >> ##################################################################

>> >> ######

>> >>

>> >> To unsubscribe from the FSL list, click the following link:

>> >> https://www.jiscmail.ac.uk/cgi-bin/webadmin?SUBED1=FSL&A=1

>> >>

>> >

>> > ###################################################################

>> > #####

>> >

>> > To unsubscribe from the FSL list, click the following link:

>> > https://www.jiscmail.ac.uk/cgi-bin/webadmin?SUBED1=FSL&A=1

>> >

>>

>> #####################################################################

>> ###

>>

>> To unsubscribe from the FSL list, click the following link:

>> https://www.jiscmail.ac.uk/cgi-bin/webadmin?SUBED1=FSL&A=1

>>

>

> ######################################################################

> ##

>

> To unsubscribe from the FSL list, click the following link:

> https://www.jiscmail.ac.uk/cgi-bin/webadmin?SUBED1=FSL&A=1

>



########################################################################



To unsubscribe from the FSL list, click the following link:

https://www.jiscmail.ac.uk/cgi-bin/webadmin?SUBED1=FSL&A=1



########################################################################



To unsubscribe from the FSL list, click the following link:

https://www.jiscmail.ac.uk/cgi-bin/webadmin?SUBED1=FSL&A=1

Top of Message | Previous Page | Permalink

JiscMail Tools


RSS Feeds and Sharing


Advanced Options


Archives

September 2019
August 2019
July 2019
June 2019
May 2019
April 2019
March 2019
February 2019
January 2019
December 2018
November 2018
October 2018
September 2018
August 2018
July 2018
June 2018
May 2018
April 2018
March 2018
February 2018
January 2018
December 2017
November 2017
October 2017
September 2017
August 2017
July 2017
June 2017
May 2017
April 2017
March 2017
February 2017
January 2017
December 2016
November 2016
October 2016
September 2016
August 2016
July 2016
June 2016
May 2016
April 2016
March 2016
February 2016
January 2016
December 2015
November 2015
October 2015
September 2015
August 2015
July 2015
June 2015
May 2015
April 2015
March 2015
February 2015
January 2015
December 2014
November 2014
October 2014
September 2014
August 2014
July 2014
June 2014
May 2014
April 2014
March 2014
February 2014
January 2014
December 2013
November 2013
October 2013
September 2013
August 2013
July 2013
June 2013
May 2013
April 2013
March 2013
February 2013
January 2013
December 2012
November 2012
October 2012
September 2012
August 2012
July 2012
June 2012
May 2012
April 2012
March 2012
February 2012
January 2012
December 2011
November 2011
October 2011
September 2011
August 2011
July 2011
June 2011
May 2011
April 2011
March 2011
February 2011
January 2011
December 2010
November 2010
October 2010
September 2010
August 2010
July 2010
June 2010
May 2010
April 2010
March 2010
February 2010
January 2010
December 2009
November 2009
October 2009
September 2009
August 2009
July 2009
June 2009
May 2009
April 2009
March 2009
February 2009
January 2009
December 2008
November 2008
October 2008
September 2008
August 2008
July 2008
June 2008
May 2008
April 2008
March 2008
February 2008
January 2008
December 2007
November 2007
October 2007
September 2007
August 2007
July 2007
June 2007
May 2007
April 2007
March 2007
February 2007
January 2007
2006
2005
2004
2003
2002
2001


JiscMail is a Jisc service.

View our service policies at https://www.jiscmail.ac.uk/policyandsecurity/ and Jisc's privacy policy at https://www.jisc.ac.uk/website/privacy-notice

Secured by F-Secure Anti-Virus CataList Email List Search Powered by the LISTSERV Email List Manager