JiscMail Logo
Email discussion lists for the UK Education and Research communities

Help for WEBPA Archives


WEBPA Archives

WEBPA Archives


WEBPA@JISCMAIL.AC.UK


View:

Message:

[

First

|

Previous

|

Next

|

Last

]

By Topic:

[

First

|

Previous

|

Next

|

Last

]

By Author:

[

First

|

Previous

|

Next

|

Last

]

Font:

Proportional Font

LISTSERV Archives

LISTSERV Archives

WEBPA Home

WEBPA Home

WEBPA  November 2017

WEBPA November 2017

Options

Subscribe or Unsubscribe

Subscribe or Unsubscribe

Log In

Log In

Get Password

Get Password

Subject:

Re: Blackboard integration

From:

Stephen P Vickers <[log in to unmask]>

Reply-To:

WebPA <[log in to unmask]>

Date:

Mon, 27 Nov 2017 10:54:47 +0000

Content-Type:

text/plain

Parts/Attachments:

Parts/Attachments

text/plain (409 lines)

You should get a more detailed error message logged in the bb-services log 
file.  If not, try adding a custom parameter of debug=true to the launch; 
this should cause the more technical error to be displayed to be user.

Stephen


On 27 November 2017 10:46:29 a.m. Tom Salyers <[log in to unmask]> 
wrote:

> Hi, Stephen.
>
> We've got a test environment with a more recent version of the building
> block installed (3.2.1), which I decided to test with before trying to
> update the one on our staging server. It's behaving even more oddly. The
> LTI settings are (as far as I can tell) identical to the other system, but
> one course with a couple of existing WebPA links will connect and show me
> the WebPA page in a frame as you'd expect. Any subsequent links we add,
> though, come back with a "Sorry, there was an error connecting you to the
> application" message, and I can't find any indication of what's wrong in
> the logs.
>
> As far as I can see, the WebPA server has everything installed that it
> needs; MySQL has the proper tables set up, the PHP extension is installed
> where it needs to be, and so on. Do you have any idea what might be going
> on? Thanks in advance--this one is stumping me a bit.
>
> --
> Tom Salyers
> VLE Developer
>
> The University of Sheffield
> Corporate Information & Computing Services (CiCS)
> 10-12 Brunswick Street
> Sheffield, S10 2FN
> Tel:  0114 222 1141
> [log in to unmask]
>
> On Thu, Nov 16, 2017 at 9:56 AM, Stephen P Vickers <
> [log in to unmask]> wrote:
>
>> Yes, settings are not lost when the building block is deleted or updated.
>>
>> Stephen
>>
>> On 16/11/17 09:24, Tom Salyers wrote:
>>
>>> Stephen--
>>>
>>> Regarding updating the LTI building block...will it retain its existing
>>> tool settings? Or if not, is there a way to export them all?
>>>
>>> --
>>> Tom Salyers
>>> VLE Developer
>>>
>>> The University of Sheffield
>>> Corporate Information & Computing Services (CiCS)
>>> 10-12 Brunswick Street
>>> Sheffield, S10 2FN
>>> Tel:  0114 222 1141
>>> [log in to unmask] <mailto:[log in to unmask]>
>>>
>>> On Tue, Nov 14, 2017 at 3:42 PM, Smith, John <[log in to unmask]
>>> <mailto:[log in to unmask]>> wrote:
>>>
>>>     Hi Tom
>>>
>>>
>>>     ?Ha ha, sorry I didn't notice that. It does seem strange though that
>>>     you are experiencing LTI issues with 2 system at a similar time...
>>>
>>>
>>>     Regards,
>>>
>>>     John Smith
>>>     Learning Technologist | School of Health & Life Sciences
>>>
>>>     T: +44 (0)141 331 3989 <tel:+44%20141%20331%203989> | E:
>>>     [log in to unmask] <mailto:[log in to unmask]>
>>>     Glasgow Caledonian University, Cowcaddens Road, Glasgow, G4 0BA,
>>>     Scotland, United Kingdom
>>>
>>>     **** Please note all Learning and Teaching enquiries MUST be sent to
>>>     our shared Blended Learning inbox at [log in to unmask]
>>>     <mailto:[log in to unmask]> and one of the School Learning
>>>     Technologists will respond. ****
>>>     ------------------------------------------------------------
>>> ------------
>>>     *From:* WebPA <[log in to unmask] <mailto:[log in to unmask]>>
>>>     on behalf of Tom Salyers <[log in to unmask]
>>>     <mailto:[log in to unmask]>>
>>>     *Sent:* 14 November 2017 15:38
>>>
>>>     *To:* [log in to unmask] <mailto:[log in to unmask]>
>>>     *Subject:* Re: Blackboard integration
>>>     Hi, John.
>>>
>>>     Heh. Yeah, that's actually me there. I'm having the same problem in
>>>     two places, it seems.
>>>
>>>     --
>>>     Tom Salyers
>>>     VLE Developer
>>>
>>>     The University of Sheffield
>>>     Corporate Information & Computing Services (CiCS)
>>>     10-12 Brunswick Street
>>>     <https://maps.google.com/?q=10-12+Brunswick+Street%0D+Sheffi
>>> eld,+S10&entry=gmail&source=g>
>>>     Sheffield, S10
>>>     <https://maps.google.com/?q=10-12+Brunswick+Street%0D+Sheffi
>>> eld,+S10&entry=gmail&source=g>
>>>     2FN
>>>     Tel:  0114 222 1141
>>>     [log in to unmask] <mailto:[log in to unmask]>
>>>
>>>     On Tue, Nov 14, 2017 at 3:35 PM, Smith, John <[log in to unmask]
>>>     <mailto:[log in to unmask]>> wrote:
>>>
>>>         Here's a link
>>>         http://www.xerte.org.uk/index.php?option=com_kunena&view=top
>>> ic&catid=10&id=1403&Itemid=759&lang=en#4796
>>>         <http://www.xerte.org.uk/index.php?option=com_kunena&view=
>>> topic&catid=10&id=1403&Itemid=759&lang=en#4796>
>>>         ?
>>>
>>>
>>>         Regards,
>>>
>>>         John Smith
>>>         Learning Technologist | School of Health & Life Sciences
>>>
>>>         T: +44 (0)141 331 3989 <tel:+44%20141%20331%203989> | E:
>>>         [log in to unmask] <mailto:[log in to unmask]>
>>>         Glasgow Caledonian University, Cowcaddens Road, Glasgow, G4 0BA,
>>>         Scotland, United Kingdom
>>>
>>>         **** Please note all Learning and Teaching enquiries MUST be
>>>         sent to our shared Blended Learning inbox at [log in to unmask]
>>>         <mailto:[log in to unmask]> and one of the School Learning
>>>         Technologists will respond. ****
>>>         ------------------------------------------------------------
>>> ------------
>>>         *From:* WebPA <[log in to unmask]
>>>         <mailto:[log in to unmask]>> on behalf of Tom Salyers
>>>         <[log in to unmask] <mailto:[log in to unmask]>>
>>>         *Sent:* 14 November 2017 15:32
>>>         *To:* [log in to unmask] <mailto:[log in to unmask]>
>>>         *Subject:* Re: Blackboard integration
>>>         I'll have to check with my coworkers, but I think no one is
>>>         entirely sure when it stopped working properly, unfortunately--I
>>>         get the impression WebPA wasn't heavily used (if it was used at
>>>         all) over the summer. I'll try updating the building block and
>>>         I'll let you know what happens.
>>>
>>>         --
>>>         Tom Salyers
>>>         VLE Developer
>>>
>>>         The University of Sheffield
>>>         Corporate Information & Computing Services (CiCS)
>>>         10-12 Brunswick Street
>>>         <https://maps.google.com/?q=10-12+Brunswick+Street%0D+Sheffi
>>> eld,+S10&entry=gmail&source=g>
>>>         Sheffield, S10
>>>         <https://maps.google.com/?q=10-12+Brunswick+Street%0D+Sheffi
>>> eld,+S10&entry=gmail&source=g>
>>>         2FN
>>>         Tel:  0114 222 1141
>>>         [log in to unmask] <mailto:[log in to unmask]>
>>>
>>>         On Tue, Nov 14, 2017 at 3:23 PM, Stephen P Vickers
>>>         <[log in to unmask]
>>>         <mailto:[log in to unmask]>> wrote:
>>>
>>>             I see no reason why it should not be working with that
>>>             version of Learn 9.  Have you seen it working since
>>>             upgrading to Q2 2017?  However, the version of the building
>>>             block is now 2.5 years old, I would recommend that you try
>>>             updating this to see if that has any effect.
>>>
>>>             Stephen
>>>
>>>             On 14/11/17 15:14, Tom Salyers wrote:
>>>
>>>                 Installation details in Blackboard says we're running
>>>                 3200.0.2-rel.37+f07d42b, and the BasicLTI building block
>>>                 version is 3.1.0.
>>>
>>>                 --
>>>                 Tom Salyers
>>>                 VLE Developer
>>>
>>>                 The University of Sheffield
>>>                 Corporate Information & Computing Services (CiCS)
>>>                 10-12 Brunswick Street
>>>                 <https://maps.google.com/?q=10
>>> -12+Brunswick+Street+%0D+Sheffield,+S10&entry=gmail&source=g>
>>>                 Sheffield, S10
>>>                 <https://maps.google.com/?q=10
>>> -12+Brunswick+Street%0D+Sheffield,+S10+%3Chttps://maps.
>>> google.com/?q%3D10-12%2BBrunswick%2BStreet%250D%2BSheffield,
>>> %2BS10%26entry%3Dgmail%26source%3Dg%3E&entry=gmail&source=g>
>>>                 2FN
>>>                 Tel:  0114 222 1141
>>>                 [log in to unmask]
>>>                 <mailto:[log in to unmask]>
>>>                 <mailto:[log in to unmask]
>>>                 <mailto:[log in to unmask]>>
>>>
>>>                 On Tue, Nov 14, 2017 at 3:10 PM, Stephen P Vickers
>>>                 <[log in to unmask]
>>>                 <mailto:[log in to unmask]>
>>>                 <mailto:[log in to unmask]
>>>                 <mailto:[log in to unmask]>>> wrote:
>>>
>>>                      What version of Learn 9 are you running and what
>>>                 version of the
>>>                      BasicLTI building block is installed?
>>>
>>>                      Stephen
>>>
>>>                      On 14/11/17 15:08, Tom Salyers wrote:
>>>
>>>                          Hi, Stephen.
>>>
>>>                          I know we had an upgrade back in mid-August,
>>>                 but I'll have to
>>>                          check to see if we've had any subsequent
>>>                 updates. We're using
>>>                          the BasicLTI building block, and as far as I
>>>                 can tell, all of
>>>                          the connections to the other tools are working
>>>                 all right with
>>>                          the exception of two--a second one to WebPA
>>>                 we've set up for
>>>                          testing (which doesn't work at all), and a link
>>>                 to Xerte.
>>>                          (Incidentally, the Xerte link is exhibiting
>>>                 some of the same
>>>                          persistent-link, one-entry-per-course behavior.
>>>                 I don't know if
>>>                 there's some connection between the tw
>>>                 <https://maps.google.com/?q=th
>>> ere's+some+connection+between+the+tw&entry=gmail&source=g>o
>>>                 problems.)
>>>
>>>                          --
>>>                          Tom Salyers
>>>                          VLE Developer
>>>
>>>                          The University of Sheffield
>>>                          Corporate Information & Computing Services (CiCS)
>>>                 10-12 Brunswick Street
>>>                 <https://maps.google.com/?q=10
>>> -12+Brunswick+Street+%0D+%C2%A0+%C2%A0+%C2%A0+%C2%A0+Sheffi
>>> eld,+S10&entry=gmail&source=g>
>>>                 Sheffield, S10
>>>                 <https://maps.google.com/?q=10
>>> -12+Brunswick+Street+%0D+%C2%A0+%C2%A0+%C2%A0+%C2%A0+Sheffi
>>> eld,+S10&entry=gmail&source=g>
>>>                 2FN
>>>                          Tel:  0114 222 1141
>>>                 [log in to unmask]
>>>                 <mailto:[log in to unmask]>
>>>                 <mailto:[log in to unmask]
>>>                 <mailto:[log in to unmask]>>
>>>                          <mailto:[log in to unmask]
>>>                 <mailto:[log in to unmask]>
>>>                          <mailto:[log in to unmask]
>>>                 <mailto:[log in to unmask]>>>
>>>
>>>
>>>                          On Tue, Nov 14, 2017 at 3:02 PM, Stephen P
>>> Vickers
>>>                          <[log in to unmask]
>>>                 <mailto:[log in to unmask]>
>>>                          <mailto:[log in to unmask]
>>>                 <mailto:[log in to unmask]>>
>>>                          <mailto:[log in to unmask]
>>>                 <mailto:[log in to unmask]>
>>>
>>>                          <mailto:[log in to unmask]
>>>                 <mailto:[log in to unmask]>>>> wrote:
>>>
>>>                               This sounds like very odd behaviour.
>>>
>>>                               Has your Learn server been updated
>>>                 recently?  Are you using the
>>>                               BasicLTI building block to connect to
>>>                 WebPA, or the core LTI
>>>                               functionality in Learn 9, or something
>>>                 else?  Are all other LTI
>>>                               connections configured in the same way
>>>                 working?
>>>
>>>                               Stephen
>>>
>>>
>>>                               On 14/11/17 14:48, Tom Salyers wrote:
>>>
>>>                                   Hello, all.
>>>
>>>                                   We've got an odd problem with our
>>>                 WebPA installation, or
>>>                                   possibly with the way our Blackboard
>>>                 system is talking
>>>                          to it,
>>>                                   and I hope someone can give me an idea
>>>                 of what's going on.
>>>
>>>                                   After working normally for a while,
>>>                 recently (within
>>>                          the last
>>>                                   five to six months) WebPA has started
>>>                 behaving
>>>                          unexpectly. You
>>>                                   can still create a form and assessment
>>>                 and link to them
>>>                          from a
>>>                                   course in Blackboard, but then:
>>>
>>>                                   - Any subsequent WebPA entries created
>>>                 in that course
>>>                          will point
>>>                                   to the same assessment as the previous
>>>                 one.
>>>
>>>                                   - Any changes in one entry will be
>>>                 reflected in the
>>>                          other(s).
>>>
>>>                                   - Only one column will be created in
>>>                 the grade centre,
>>>                                   regardless of how many WebPA entries
>>>                 are on the course.
>>>
>>>                          This is just an educated specul
>>>                 <https://maps.google.com/?q=%C
>>> 2%A0+%C2%A0+%C2%A0+%C2%A0+This+is+just+an+educated+specul&
>>> entry=gmail&source=g>ation--I'm
>>>                 new to WebPA, and
>>>                                   new-ish to Blackboard--but it sounds
>>>                 as if an initial
>>>                          database
>>>                                   record is being created when the first
>>>                 WebPA link is
>>>                          created,
>>>                                   and then every link after that points
>>>                 to the same record.
>>>
>>>                                   I could be wrong, of course. Has
>>>                 anyone had a similar
>>>                          problem,
>>>                                   or have any insight to what might be
>>>                 going on? Thanks
>>>                          in advance.
>>>
>>>                                   --
>>>                                   Tom Salyers
>>>                                   VLE Developer
>>>
>>>                                   The University of Sheffield
>>>                                   Corporate Information & Computing
>>>                 Services (CiCS)
>>>                 10-12 Brunswick Street
>>>                 <https://maps.google.com/?q=10
>>> -12+Brunswick+Street+%0D+%C2%A0+%C2%A0+%C2%A0+%C2%A0+%C2%
>>> A0%C2%A0+%C2%A0+%C2%A0+%C2%A0+Sheffield,+S10&entry=gmail&source=g>
>>>                 Sheffield, S10
>>>                 <https://maps.google.com/?q=10
>>> -12+Brunswick+Street+%0D+%C2%A0+%C2%A0+%C2%A0+%C2%A0+%C2%
>>> A0%C2%A0+%C2%A0+%C2%A0+%C2%A0+Sheffield,+S10&entry=gmail&source=g>
>>>                 2FN
>>>                                   Tel:  0114 222 1141
>>>                 [log in to unmask]
>>>                 <mailto:[log in to unmask]>
>>>                 <mailto:[log in to unmask]
>>>                 <mailto:[log in to unmask]>>
>>>                          <mailto:[log in to unmask]
>>>                 <mailto:[log in to unmask]>
>>>                          <mailto:[log in to unmask]
>>>                 <mailto:[log in to unmask]>>>
>>>                                   <mailto:[log in to unmask]
>>>                 <mailto:[log in to unmask]>
>>>                          <mailto:[log in to unmask]
>>>                 <mailto:[log in to unmask]>>
>>>                                   <mailto:[log in to unmask]
>>>                 <mailto:[log in to unmask]>
>>>                          <mailto:[log in to unmask]
>>>                 <mailto:[log in to unmask]>>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>         Glasgow Caledonian University is a registered Scottish charity,
>>>         number SC021474
>>>
>>>
>>>
>>>
>>>     Glasgow Caledonian University is a registered Scottish charity,
>>>     number SC021474
>>>
>>>
>>>

Top of Message | Previous Page | Permalink

JiscMail Tools


RSS Feeds and Sharing


Advanced Options


Archives

November 2017
August 2017
July 2017
June 2017
May 2017
April 2017
March 2017
February 2017
January 2017
December 2016
November 2016
October 2016
September 2016
August 2016
June 2016
May 2016
April 2016
March 2016
February 2016
January 2016
December 2015
November 2015
October 2015
September 2015
August 2015
July 2015
June 2015
May 2015
April 2015
March 2015
February 2015
January 2015
December 2014
November 2014
October 2014
September 2014
August 2014
July 2014
June 2014
May 2014
April 2014
March 2014
February 2014
January 2014
December 2013
November 2013
October 2013
September 2013
August 2013
June 2013
May 2013
April 2013
March 2013
February 2013
January 2013
December 2012
November 2012
October 2012
September 2012
August 2012
July 2012
June 2012
April 2012
March 2012
February 2012
January 2012
December 2011
November 2011
September 2011
August 2011
July 2011
June 2011
May 2011
April 2011
March 2011
February 2011
January 2011
December 2010
November 2010
October 2010
September 2010
August 2010
July 2010
June 2010
May 2010
April 2010
March 2010
February 2010
January 2010
December 2009
November 2009
October 2009
September 2009
August 2009
July 2009
June 2009
May 2009
April 2009
March 2009
February 2009
January 2009
December 2008
November 2008
October 2008
September 2008
June 2008
May 2008
April 2008
February 2008
December 2007
November 2007
October 2007
September 2007
August 2007
July 2007
June 2007
May 2007
March 2007


WWW.JISCMAIL.AC.UK

Secured by F-Secure Anti-Virus CataList Email List Search Powered by the LISTSERV Email List Manager