JiscMail Logo
Email discussion lists for the UK Education and Research communities

Help for WEBPA Archives


WEBPA Archives

WEBPA Archives


WEBPA@JISCMAIL.AC.UK


View:

Message:

[

First

|

Previous

|

Next

|

Last

]

By Topic:

[

First

|

Previous

|

Next

|

Last

]

By Author:

[

First

|

Previous

|

Next

|

Last

]

Font:

Proportional Font

LISTSERV Archives

LISTSERV Archives

WEBPA Home

WEBPA Home

WEBPA  August 2015

WEBPA August 2015

Options

Subscribe or Unsubscribe

Subscribe or Unsubscribe

Log In

Log In

Get Password

Get Password

Subject:

Re: Trial LTI

From:

Stephen P Vickers <[log in to unmask]>

Reply-To:

WebPA <[log in to unmask]>

Date:

Mon, 10 Aug 2015 10:45:45 +0100

Content-Type:

text/plain

Parts/Attachments:

Parts/Attachments

text/plain (76 lines)

Try using a value of "true" - it does not work the same when using "yes".

For direct support either try using the forum in OSCELOT where the LTI 
connector for WebPA is made available (see 
http://www.spvsoftwareproducts.com/php/webpa-lti/) or contact me 
directly and I will try to help.

Stephen

On 10/08/2015 10:38, Osborne, Brian wrote:
> Hi Stephen,
>
> I have added a parameter of "debug" with a value of "yes" and I'm still getting a response of "Error: Sorry, there was an error connecting you to the application.".
>
> Is there a support email address for the ceLTIc project?
>
> Thanks,
> Brian
>
> -----Original Message-----
> From: WebPA [mailto:[log in to unmask]] On Behalf Of Stephen P Vickers
> Sent: 10 August 2015 10:22
> To: [log in to unmask]
> Subject: Re: Trial LTI
>
> This trial service is offered by the ceLTIc project, not by the WebPA project.
>
> If you send a custom parameter named "debug" with a value of "true" you should see a more informative error message.  Alternatively, if your tool consumer supports the error log option, this error message should also be found in its log files.
>
> Stephen
>
> On 10/08/2015 08:45, Osborne, Brian wrote:
>> I have signed up for your 14 day trial and I am posting to your
>> service, but I always receive a response back that reads “Error:
>> Sorry, there was an error connecting you to the application.”.
>>
>> My POST data is:
>>
>> *Calling:*http://eval.ltiapps.net/webpa/mod/lti/ (or
>> http://eval.ltiapps.net/webpa/mod/lti/index.php)
>>
>>
>> *Shared secret:* "E38uVDmEgBbPs0crd7w4ZGqFwYBlrR3v"
>>
>> *Encoded Signature Params:* "
>> POST&http%3A%2F%2Feval.ltiapps.net%2Fwebpa%2Fmod%2Flti%2F&ext_basiclti_submit%3DPress%2520to%2520continue%2520to%2520external%2520tool%26launch_presentation_document_target%3Diframe%26launch_presentation_height%3D240%26launch_presentation_locale%3Den-GB%26launch_presentation_width%3D320%26lis_result_sourcedid%3DStudyNet%26lti_message_type%3Dbasic-lti-launch-request%26lti_version%3DLTI-1p0%26oauth_consumer_key%3DDVMQPCE2-SDYX-TRZN-8MEF-BCTWQPR5ZSQS%26oauth_nonce%3DJ98SFfiYs11Lk47ue2QnplNpFKqE0ht0%26oauth_signature_method%3DHMAC-SHA1%26oauth_timestamp%3D1438956933%26oauth_version%3D1.0%26roles%3DInstructor%26tool_consumer_info_product_family_code%3DStudyNet%26tool_consumer_info_version%3D2015%26tool_consumer_instance_contact_email%3Dltdu%2540herts.ac.uk%26tool_consumer_instance_description%3DUniversity%2520of%2520Hertfordshire%2520%2528StudyNet%2529%26tool_consumer_instance_guid%3Dstudynet.herts.ac.uk%26tool_consumer_instance_name%3DStudyNet"
>>
>> *HEADER X-Authorization*
>> OAuth realm => "http://eval.ltiapps.net/webpa/mod/lti/"
>> oauth_nonce => "J98SFfiYs11Lk47ue2QnplNpFKqE0ht0"
>> oauth_signature => "6778472f726b646651454776674267715539397966413d3d"
>> oauth_consumer_key => "DVMQPCE2-SDYX-TRZN-8MEF-BCTWQPR5ZSQS"
>> oauth_signature_method => "HMAC-SHA1"
>> oauth_version => "1.0"
>> oauth_timestamp => "1438956933"
>>
>> *POST BODY*
>> tool_consumer_info_product_family_code=StudyNet&lti_version=LTI-1p0&ro
>> les=Instructor&tool_consumer_instance_name=StudyNet&tool_consumer_inst
>> ance_description=University%20of%20Hertfordshire%20%28StudyNet%29&laun
>> ch_presentation_width=320&tool_consumer_instance_guid=studynet.herts.a
>> c.uk&ext_basiclti_submit=Press%20to%20continue%20to%20external%20tool&
>> launch_presentation_locale=en-GB&tool_consumer_instance_contact_email=
>> ltdu%40herts.ac.uk&lis_result_sourcedid=StudyNet&lti_message_type=basi
>> c-lti-launch-request&tool_consumer_info_version=2015&launch_presentati
>> on_height=240&launch_presentation_document_target=iframe
>>
>> Any idea what is wrong, or is it possible to change the response
>> message to indicate the issue rather than just say there has been an error?
>>
>> Thanks,
>>
>> Brian Osborne
>>
>> University of Hertfordshire
>>

Top of Message | Previous Page | Permalink

JiscMail Tools


RSS Feeds and Sharing


Advanced Options


Archives

November 2017
August 2017
July 2017
June 2017
May 2017
April 2017
March 2017
February 2017
January 2017
December 2016
November 2016
October 2016
September 2016
August 2016
June 2016
May 2016
April 2016
March 2016
February 2016
January 2016
December 2015
November 2015
October 2015
September 2015
August 2015
July 2015
June 2015
May 2015
April 2015
March 2015
February 2015
January 2015
December 2014
November 2014
October 2014
September 2014
August 2014
July 2014
June 2014
May 2014
April 2014
March 2014
February 2014
January 2014
December 2013
November 2013
October 2013
September 2013
August 2013
June 2013
May 2013
April 2013
March 2013
February 2013
January 2013
December 2012
November 2012
October 2012
September 2012
August 2012
July 2012
June 2012
April 2012
March 2012
February 2012
January 2012
December 2011
November 2011
September 2011
August 2011
July 2011
June 2011
May 2011
April 2011
March 2011
February 2011
January 2011
December 2010
November 2010
October 2010
September 2010
August 2010
July 2010
June 2010
May 2010
April 2010
March 2010
February 2010
January 2010
December 2009
November 2009
October 2009
September 2009
August 2009
July 2009
June 2009
May 2009
April 2009
March 2009
February 2009
January 2009
December 2008
November 2008
October 2008
September 2008
June 2008
May 2008
April 2008
February 2008
December 2007
November 2007
October 2007
September 2007
August 2007
July 2007
June 2007
May 2007
March 2007


WWW.JISCMAIL.AC.UK

Secured by F-Secure Anti-Virus CataList Email List Search Powered by the LISTSERV Email List Manager