JiscMail Logo
Email discussion lists for the UK Education and Research communities

Help for LCG-ROLLOUT Archives


LCG-ROLLOUT Archives

LCG-ROLLOUT Archives


LCG-ROLLOUT@JISCMAIL.AC.UK


View:

Message:

[

First

|

Previous

|

Next

|

Last

]

By Topic:

[

First

|

Previous

|

Next

|

Last

]

By Author:

[

First

|

Previous

|

Next

|

Last

]

Font:

Proportional Font

LISTSERV Archives

LISTSERV Archives

LCG-ROLLOUT Home

LCG-ROLLOUT Home

LCG-ROLLOUT  April 2007

LCG-ROLLOUT April 2007

Options

Subscribe or Unsubscribe

Subscribe or Unsubscribe

Log In

Log In

Get Password

Get Password

Subject:

Re: Having problems install glite-WN_sl4compat on SLC4 32 bit machines

From:

Gonçalo Borges <[log in to unmask]>

Reply-To:

LHC Computer Grid - Rollout <[log in to unmask]>

Date:

Thu, 12 Apr 2007 11:33:06 +0100

Content-Type:

text/plain

Parts/Attachments:

Parts/Attachments

text/plain (219 lines)

Hi All,

Here I send you the messages me and Mario  have exchanged with Markus...

Cheers
Goncalo Borges

####

Hi Markus,

I have been checking with my colleagues (and in my notes) what we did 
for installing gLite under SL4.
As fair as I can remember, one of the main motivations was that we were 
needing NFS4 shared directories, with kerberos support, and NFS3 was not 
stable enough for our needs.
The second motivation was just to see if we were able to do it since SL4 
would become the official CERN distribution is a short time.
Now we have a CE (ce02.lip.pt) in production and another CE 
(pprod03.lip.pt) in pre-production running in this way.
Obviously, we just did what was possible to us, namely changing some rpm 
dependencies or re-compiling some packages.

Mario David sent an email to LCG-ROLLOUT on the 6th June 2006 explaining 
what we did, but I'll summarize hereafter:

For almost/all the nodes there are some dependencies problems which were 
solved by taking the packages from SL3:
  a) commons-logging-* and libgcj-ssa ;
  b) torque* needs  libtcl8.3.so and libtk8.3.so (exactly) and so we 
forced a "nodeps" for the torque;
  c) classads-g3 needs libstdc++ = 3.2.3 (exactly) and so we installed 
compat-libstdc++-33-3.2.3-47.3 (from sl4 normal repo).

These changes worked for the SE (dcache, dpm), LFC and MON nodes. 
However, in the lcg-CE node, the openldap 2.2-** (from the SL4) gives 
problems for the site bdii, with errors on the slapadd into the bdii 
database. It seems the version 2.2 is stricter than 2.0. Therefore, we 
have compiled openldap 2.0-** in sl4 and downgraded the package and now 
it seems to work OK.

The real problem arises in the glite-UI and glite-WN, namelly when you 
run yaim function config_glite.  Here, you really need python 2.2 
(whereas python 2.3 comes in SL4).
The problematic packages are PyXML and 4Suite (at least xpath function). 
To solve this issue, we have profit from a Valentim Vidic's suggestion, 
and we have copied the directory /usr/lib/python2.2 and 
/usr/bin/python2.2 from a SL3 machine to our SL4 nodes. So, everytime we 
need to run yaim, we just point /usr/bin/python to /usr/bin/python2.2.
After running the yaim configuration, we return to python2.3 because we 
are afraid for the OS to break.

And until now everything seems to be working. However, it is really hard 
every time we need to perform updates in the middleware because the 
middleware checks for specific versions of some packages (which can be 
different under SL4) and this takes more time than usual. You can also 
not run "apt-get" with  python2.3 and we perfom the updates using "yaim".

I just describe in a few lines a week of work.
I hope this information fits your needs.

Best Regards
Goncalo

###

Mario David wrote:
> Hi Louis
>
> I had sent a mail a long ago to Markus when he asked me most of this 
> stuff
> that mail contains a lot more details than this one
>
> cheers
>
> Mario
>
> Quoting Louis Poncet <[log in to unmask]>:
>
>> Mario thanks a lot we will use thoses informations for the repository
>> creation (we were aware of python and some other = problems in dep list.
>> But again those pkg are not compile on the proper Os.
>>
>>
>> Lp
>> -- 
>> Laird Louis Poncet
>> Where: Bat28-R-003 CERN
>> CH-1211 Geneve 23
>> Mail : [log in to unmask]
>> Phone: +41(0)227.674.231
>> LAL / IN2P3 / CNRS / CERN
>>
>>
>>
>> Le 11 avr. 07 à 12:36, Mario David a écrit :
>>
>>> Hi Louis and all
>>>
>>> by now I am used to that this issue comes in waves to the lcg   
>>> rollout from time to time.
>>>
>>> at LIP-Lisbon we have
>>> PPS-LIP fully slc4 for a long time, meaning
>>> lcg-CE (containing the site bdii)
>>> DPM
>>> dCache
>>> LFC
>>> all WN's
>>> UI
>>> MON
>>>
>>> the UI was one of the most problematic simply because of the
>>> glite-ui-config, which had to be python 2.2 (were 2.3 is on the   
>>> distro of slc4)
>>> this was solved in the meantime, don't remember which patch
>>>
>>> DPM dCache and LFC and MON were rather straight forward after you   
>>> add some packages from the slc3 (don't need to downgrade anything   
>>> as far as I remember)
>>>
>>> the WN's you already have now
>>>
>>> for the lcg-CE (don't have experience with glite-CE) there was a   
>>> problem with the torque wanting to have tcl/tk 8.3 , we forced it
>>> I never knew  why torque depends = tcl/tk 8.3 and not a depends on  
>>> >= 8.3
>>> so we have 8.4, and --forced the install of the torque
>>> we never experience any problems because of this
>>>
>>>
>>> finally the BDII (either site or top)
>>> it installs with no problem, the problem arises after you query the 
>>>   ldap and see wrong or missing information
>>> so, in slc3 you have openldap 2.0, while slc4 you have openldap 2.2
>>> a matter of downgrading from 2.2 to 2.0 is far from being feasible  
>>>  because a lot of rpm in slc4 depends on that guy
>>> so we recompiled ldap 2.0 in slc4, and included thing like the ldap 
>>>   lib of 2.2 on that rpm
>>>
>>> down to it, 2.2 is backward incompatible with 2.0, the ldapadd of   
>>> 2.2 is more strict than 2.0, and the way the info plugins are done, 
>>>   you see errors of ldapadd on the ldap logs because of it.
>>>
>>> and that about a little of that story
>>>
>>> cheers
>>>
>>> Mario David
>>>
>>> Quoting Louis Poncet <[log in to unmask]>:
>>>
>>>> We are nto certifying yet the SL4 othere services.
>>>> We didn't want to play the magician managing package create on  
>>>> SL3  and
>>>> mixing them with what we have that already compile on SL4.
>>>>
>>>> So we are waiting for the properly compile package for SL4.
>>>>
>>>> (The BDII should work without any problem)
>>>>
>>>> But i am sorry to ask you to wait a bit more time to get the other
>>>> services on the SL4 Os.
>>>>
>>>> -- 
>>>> Laird Louis Poncet
>>>> Where: Bat28-R-003 CERN
>>>> CH-1211 Geneve 23
>>>> Mail : [log in to unmask]
>>>> Phone: +41(0)227.674.231
>>>> LAL / IN2P3 / CNRS / CERN
>>>>
>>>>
>>>>
>>>> Le 11 avr. 07 à 10:11, Nikolaos Vidiadakis a écrit :
>>>>
>>>>> I am sorry if I miswrote what I wanted to ask. I only wanted to   
>>>>>   know if someone has installed other roles like glite_CE or   
>>>>> glite_SE  on SL44. Is it diffucult to be setup'd like this? I   
>>>>> assume that an   installation approach similar to the one   
>>>>> followed for the WN's has   to be followed (meaning installing   
>>>>> packages from 30X repositories).
>>>>>
>>>>> On 4/11/07, Louis Poncet <[log in to unmask]> wrote:
>>>>> Good morning.
>>>>>
>>>>> I am sorry but i don't understand what you mean by out of the box.
>>>>>
>>>>> Lp
>>>>> -- 
>>>>> Laird Louis Poncet
>>>>> Where: Bat28-R-003 CERN
>>>>> CH-1211 Geneve 23
>>>>> Mail : [log in to unmask]
>>>>> Phone: +41(0)227.674.231
>>>>> LAL / IN2P3 / CNRS / CERN
>>>>>
>>>>>
>>>>>
>>>>> Le 11 avr. 07 à 07:16, Nikolaos Vidiadakis a écrit :
>>>>>
>>>>>> Good morning to all,
>>>>>>
>>>>>> Just curious, all other roles like glite_CE or glite_SE or  even 
>>>>>>    BDII can be installed "out of the box" on SL44? As a   
>>>>>> procedure, is  it similar to the one used for the WN's? Does   
>>>>>> anyone have such a  configuration?
>>>>>>
>>>>>> On 4/10/07, Vladimir Fekete < [log in to unmask]>  
>>>>>> wrote:
>>>>>>
>>>>>> ...
>>>>>>
>>>>>> I need a help with installation of  glite-WN_sl4compat on SLC4   
>>>>>> (32bit).
>>>>>> ...
>>>>>
>>>>>

Top of Message | Previous Page | Permalink

JiscMail Tools


RSS Feeds and Sharing


Advanced Options


Archives

March 2020
February 2020
January 2020
November 2019
October 2019
September 2019
August 2019
July 2019
June 2019
May 2019
March 2019
February 2019
January 2019
December 2018
November 2018
October 2018
September 2018
August 2018
July 2018
June 2018
May 2018
April 2018
February 2018
January 2018
November 2017
October 2017
September 2017
July 2017
June 2017
May 2017
March 2017
February 2017
January 2017
December 2016
November 2016
October 2016
September 2016
August 2016
July 2016
June 2016
May 2016
April 2016
March 2016
February 2016
January 2016
December 2015
November 2015
October 2015
September 2015
August 2015
July 2015
June 2015
May 2015
April 2015
March 2015
February 2015
January 2015
December 2014
November 2014
October 2014
September 2014
August 2014
July 2014
June 2014
May 2014
April 2014
March 2014
February 2014
January 2014
December 2013
November 2013
October 2013
September 2013
August 2013
July 2013
June 2013
May 2013
April 2013
March 2013
February 2013
January 2013
December 2012
November 2012
October 2012
September 2012
August 2012
July 2012
June 2012
May 2012
April 2012
March 2012
February 2012
January 2012
December 2011
November 2011
October 2011
September 2011
August 2011
July 2011
June 2011
May 2011
April 2011
March 2011
February 2011
January 2011
December 2010
November 2010
October 2010
September 2010
August 2010
July 2010
June 2010
May 2010
April 2010
March 2010
February 2010
January 2010
December 2009
November 2009
October 2009
September 2009
August 2009
July 2009
June 2009
May 2009
April 2009
March 2009
February 2009
January 2009
December 2008
November 2008
October 2008
September 2008
August 2008
July 2008
June 2008
May 2008
April 2008
March 2008
February 2008
January 2008
December 2007
November 2007
October 2007
September 2007
August 2007
July 2007
June 2007
May 2007
April 2007
March 2007
February 2007
January 2007
2006
2005
2004
2003


JiscMail is a Jisc service.

View our service policies at https://www.jiscmail.ac.uk/policyandsecurity/ and Jisc's privacy policy at https://www.jisc.ac.uk/website/privacy-notice

Secured by F-Secure Anti-Virus CataList Email List Search Powered by the LISTSERV Email List Manager