JiscMail Logo
Email discussion lists for the UK Education and Research communities

Help for LCG-ROLLOUT Archives


LCG-ROLLOUT Archives

LCG-ROLLOUT Archives


LCG-ROLLOUT@JISCMAIL.AC.UK


View:

Message:

[

First

|

Previous

|

Next

|

Last

]

By Topic:

[

First

|

Previous

|

Next

|

Last

]

By Author:

[

First

|

Previous

|

Next

|

Last

]

Font:

Proportional Font

LISTSERV Archives

LISTSERV Archives

LCG-ROLLOUT Home

LCG-ROLLOUT Home

LCG-ROLLOUT  April 2007

LCG-ROLLOUT April 2007

Options

Subscribe or Unsubscribe

Subscribe or Unsubscribe

Log In

Log In

Get Password

Get Password

Subject:

Re: Having problems install glite-WN_sl4compat on SLC4 32 bit machines

From:

Branimir Ackovic <[log in to unmask]>

Reply-To:

LHC Computer Grid - Rollout <[log in to unmask]>

Date:

Tue, 10 Apr 2007 13:50:12 +0200

Content-Type:

text/plain

Parts/Attachments:

Parts/Attachments

text/plain (336 lines)

We have tclx-8.3.5-4.i386 and tk-8.4.7-2.i386 which comes with SL4.4.
You can try to download it and install from SL4.4 repo:

ftp://ftp.scientificlinux.org/linux/scientific/44/i386/SL/RPMS/

Acko





On Tue, 2007-04-10 at 13:36 +0200, Vladimir Fekete wrote:
> problem is still there :  rpm -ivh torque-client-2.1.6-1cri_sl4_2st.i386.rpm
> error: Failed dependencies:
>         libtclx8.3.so is needed by torque-client-2.1.6-1cri_sl4_2st.i386
>         libtkx8.3.so is needed by torque-client-2.1.6-1cri_sl4_2st.i386
>    Suggested resolutions:
>         tclx-8.3-92.7.i386.rpm
> 
> and suggested resolution will not help me because glite-WN bring with itself
> version 8.4 (tk) and when I try to unsintall it, apt force me to uninstall
> glite-WN too :
>  rpm -Uvh tcl-8.3.5-92.7.i386.rpm
> warning: tcl-8.3.5-92.7.i386.rpm: V3 DSA signature: NOKEY, key ID 0c98ff9d
> error: Failed dependencies:
>         libtcl8.4.so is needed by (installed) expect-5.42.1-1.i386
>         libtcl8.4.so is needed by (installed) tk-8.4.7-2.i386
>         libtcl8.4.so is needed by (installed) tix-8.1.4-98.i386
>         libtcl8.4.so is needed by (installed) tkinter-2.3.4-14.3.i386
>         tcl = 8.4.7 is needed by (installed) tk-8.4.7-2.i386
> [root@lcg20 2.1.6-1cri_sl4_2st]# apt-get remove tk
> Reading Package Lists... Done
> Building Dependency Tree... Done
> The following packages will be REMOVED:
>    edg-wl-ui-cli_gcc3_2_2 (lcg2.1.74-3_sl3)
>    glite-WN (3.0.15-3)
>    tix (1:8.1.4-98)
>    tk (8.4.7-2)
>    tkinter (2.3.4-14.3)
> 0 upgraded, 0 newly installed, 5 removed and 1 not upgraded.
> Need to get 0B of archives.
> After unpacking 32.0MB disk space will be freed.
> Do you want to continue? [Y/n] n
> Abort.
> 
>  V.
> 
> On Tue, Apr 10, 2007 at 01:27:29PM +0200, Branimir Ackovic wrote:
> > Yes that is the same version 2.1.6 but for different OS versions. We are
> > using torque 2.1.8 sl3 on CE and 2.1.8 sl4 on WNs.
> > 
> > Acko
> > 
> > 
> > On Tue, 2007-04-10 at 13:24 +0200, Vladimir Fekete wrote:
> > > Hi,
> > > 
> > >   well, but according to http://wiki.egee-see.org/index.php/SL4_WN I should
> > > use version corresponding to my torque server 
> > > 
> > >  "Please bear in mind that torque server and all torque clients need to have
> > >   the same version, so be careful with versions."
> > > 
> > > and that is 2.1.6-1cri_sl3_2st. (on CE)
> > > 
> > >  May I use SL4 torque even though server is sl3 and expect it will work ?
> > > 
> > > 
> > > 
> > >  best regards, 
> > >  V.
> > > 
> > > On Tue, Apr 10, 2007 at 01:16:52PM +0200, Branimir Ackovic wrote:
> > > > Hi Vladimir,
> > > >  
> > > > You should try torque for SL4:
> > > > 
> > > > http://hepunx.rl.ac.uk/~traylens/rpms/torque/2.1.6-1cri_sl4_2st/
> > > > 
> > > > not for SL3:
> > > > 
> > > > http://hepunx.rl.ac.uk/~traylens/rpms/torque/2.1.6-1cri_sl3_2st/
> > > > 
> > > > 
> > > > best regards,
> > > > Acko
> > > > 
> > > > -----
> > > > Branimir Ackovic
> > > > AEGIS01-PHY-SCL Grid site Manager
> > > > E-mail: [log in to unmask]
> > > > Web: http://scl.phy.bg.ac.yu/
> > > > 
> > > > Phone: +381 11 3160260, Ext. 152
> > > > Fax: +381 11 3162190
> > > > 
> > > > Scientific Computing Laboratory
> > > > Institute of Physics, Belgrade
> > > > Serbia
> > > > -----
> > > > 
> > > > 
> > > > On Tue, 2007-04-10 at 13:02 +0200, Vladimir Fekete wrote:
> > > > > Hi Acko,
> > > > > 
> > > > >   so I looked at my apt sources list and find, that when I use SLC4 apt
> > > > > source I am able to install glite-WN without dependency problem. So now
> > > > > remaining torque. 
> > > > > 
> > > > >   Problems are again dependencies :
> > > > > libraries libtcl8.3.so and libtk8.3.so. (torque-2.1.6-1cri_sl3_2st)
> > > > >     libtcl can be found in packages tclx and tcl.
> > > > >     libtk  can be found in package tk
> > > > > 
> > > > > Problem is that glite-WN installation proccess also installed tk but version
> > > > > 8.4.7-2. And tcl, tclx are also only in version 8.4.7-2. Any suggesion ? :(
> > > > > (manual installation of torque from http://hepunx.rl.ac.uk/~traylens/rpms/torque/2.1.6-1cri_sl3_2st/
> > > > >  have same dependency problem)
> > > > > 
> > > > >  V.
> > > > > 
> > > > > P.S. my /etc/apt/sources.list.d 
> > > > > 
> > > > > file: cern.list
> > > > >   rpm http://linuxsoft.cern.ch/ cern/slc4X/i386/apt os updates extras
> > > > >   rpm-src http://linuxsoft.cern.ch/ cern/slc4X/i386/apt os updates extras
> > > > > 
> > > > > file: dag.list
> > > > >   rpm http://linuxsoft.cern.ch dag/redhat/el4/en/i386 dag
> > > > > 
> > > > > file: glite.list
> > > > >   rpm http://glitesoft.cern.ch/EGEE/gLite/APT/R3.0/ rhel30 externals Release3.0 updates
> > > > >   #rpm http://lxb2042.cern.ch:/gLite/APT/R3.0-pps/ sl4 Release3.0 externals updates
> > > > > 
> > > > > file: jpackage.list
> > > > >   rpm http://linuxsoft.cern.ch/ jpackage/1.6/generic free devel
> > > > >   rpm http://linuxsoft.cern.ch/ jpackage/1.6/redhat-el-3.0 free devel
> > > > > 
> > > > > file: lcg-ca.list
> > > > >   rpm http://grid-deployment.web.cern.ch/grid-deployment/gis apt/LCG_CA/en/i386 lcg
> > > > >   rpm http://linuxsoft.cern.ch/ LCG-CAs/current production
> > > > > 
> > > > > 
> > > > > 
> > > > > On Tue, Apr 10, 2007 at 11:44:38AM +0200, Branimir Ackovic wrote:
> > > > > > Hi Vladimir,
> > > > > > 
> > > > > > on our SL4.4 WNs we have:
> > > > > > GFAL-client-1.7.8-5.i386
> > > > > > lcg_util-1.3.7-5.i386
> > > > > > 
> > > > > > Maybe you can try to manualy download and install/upgrade this packages?
> > > > > > 
> > > > > > Did you applied all remove/install steps as described on
> > > > > > http://wiki.egee-see.org/index.php/SL4_WN
> > > > > > 
> > > > > > 
> > > > > > best regards
> > > > > > Acko
> > > > > > 
> > > > > > -----
> > > > > > Branimir Ackovic
> > > > > > AEGIS01-PHY-SCL Grid site Manager
> > > > > > E-mail: [log in to unmask]
> > > > > > Web: http://scl.phy.bg.ac.yu/
> > > > > > 
> > > > > > Phone: +381 11 3160260, Ext. 152
> > > > > > Fax: +381 11 3162190
> > > > > > 
> > > > > > Scientific Computing Laboratory
> > > > > > Institute of Physics, Belgrade
> > > > > > Serbia
> > > > > > -----
> > > > > > 
> > > > > > 
> > > > > > On Tue, 2007-04-10 at 10:43 +0200, Vladimir Fekete wrote:
> > > > > > > Hi,
> > > > > > > 
> > > > > > >  Ive tryied follow your steps, but again I remained stuck with dependency
> > > > > > > problem.
> > > > > > > 
> > > > > > > After I run :
> > > > > > > 
> > > > > > > ./install_node /opt/glite/yaim/etc/site-info.def glite-WN glite-torque-client-config
> > > > > > > 
> > > > > > > I get :
> > > > > > > 
> > > > > > > The following packages have unmet dependencies:
> > > > > > >   glite-WN: Depends: edg-replica-manager (>= 1.8.1-1_sl3) but it is not	going to be installed
> > > > > > >             Depends: edg-replica-manager-test (>= 1.8.1-1_sl3) but it is not going to be installed
> > > > > > >             Depends: edg-replica-manager-gridftp-client_gcc3_2_2 (>=1.8.1-1_sl3) but it is not going to be installed
> > > > > > >             Depends: GFAL-client (>= 1.7.7-1_sl3) but it is not going to be installed
> > > > > > >             Depends: lcg_util (>= 1.3.6-1_sl3) but it is not going to be installed
> > > > > > >             Depends: edg-wl-ui-cli_gcc3_2_2 (>= lcg2.1.74-1_sl3) but it is not going to be installed
> > > > > > >   glite-torque-client-config: Depends: tclx but it is not going to be installed
> > > > > > >                               Depends: torque-client but it is not going to be installed
> > > > > > >                               Depends: torque-mom but it is not going to be installed
> > > > > > > E: Broken packages
> > > > > > > 
> > > > > > > 
> > > > > > > 
> > > > > > > When I try to solve dependenci for edg-replica-manager I get:
> > > > > > > depends on lcg_util
> > > > > > > lcg_util depends on libgfal.so, libldap.so.2
> > > > > > > libgfal.so belong to GFAL-client package
> > > > > > > GFAL-client package depends on libldap.so.2
> > > > > > > libldap.so.2 belong to openldap-alt package
> > > > > > > openldap-alt package depends on libdb-4.1.so
> > > > > > > libdb-4.1.so belong to db4 package
> > > > > > > 
> > > > > > > db4 natively installed in SLC 4.4 ahve libdb-4.2.so and you cannot just
> > > > > > > remove it beacause almost whole system depends on it (including yum)
> > > > > > > 
> > > > > > >  V. :-(
> > > > > > > 
> > > > > > > 
> > > > > > > On Tue, Apr 10, 2007 at 09:15:57AM +0200, Antun Balaz wrote:
> > > > > > > > Hi Vladimir,
> > > > > > > > 
> > > > > > > > Within SEE ROC we have addressed the problem of installation and configuration
> > > > > > > > of glite-WN over cleanly installed SL4.4 (32 bit), and you can find our notes at:
> > > > > > > > 
> > > > > > > > http://wiki.egee-see.org/index.php/SL4_WN
> > > > > > > > 
> > > > > > > > AEGIS01-PHY-SCL site currently has all its WNs installed and configured over
> > > > > > > > SL4.4.
> > > > > > > > 
> > > > > > > > This is not SLC4 as you asked, but I hope you will manage with the above notes.
> > > > > > > > 
> > > > > > > > Best regards, Antun
> > > > > > > > 
> > > > > > > > -----
> > > > > > > > Antun Balaz
> > > > > > > > Research Assistant
> > > > > > > > E-mail: [log in to unmask]
> > > > > > > > Web: http://scl.phy.bg.ac.yu/
> > > > > > > > 
> > > > > > > > Phone: +381 11 3160260, Ext. 152
> > > > > > > > Fax: +381 11 3162190
> > > > > > > > 
> > > > > > > > Scientific Computing Laboratory
> > > > > > > > Institute of Physics, Belgrade, Serbia
> > > > > > > > -----
> > > > > > > > 
> > > > > > > > ---------- Original Message -----------
> > > > > > > > From: Vladimir Fekete <[log in to unmask]>
> > > > > > > > To: [log in to unmask]
> > > > > > > > Sent: Tue, 10 Apr 2007 06:40:44 +0200
> > > > > > > > Subject: [LCG-ROLLOUT] Having problems install glite-WN_sl4compat on SLC4 32
> > > > > > > > bit machines
> > > > > > > > 
> > > > > > > > > Hi all!
> > > > > > > > > 
> > > > > > > > >   I need a help with installation of  glite-WN_sl4compat on SLC4 
> > > > > > > > > (32bit). Problem is that I cannot find any "official" way how to 
> > > > > > > > > install it, and those I have tryied failed:
> > > > > > > > > 
> > > > > > > > > URL   | https://twiki.cscs.ch/bin/view/LCGTier2/PhoenixClusterBlog
> > > > > > > > > Step  | /opt/glite/yaim/scripts/install_node site-info.def glite-
> > > > > > > > > WN_sl4compat-3.0.13-0.noarch Error | Error: Missing Dependency: 
> > > > > > > > > libXxf86vm.so.1 is needed by package xorg-x11-Mesa-libGL
> > > > > > > > > 
> > > > > > > > > URL   | 
> > > > > > > > > http://glite.web.cern.ch/glite/packages/R3.0/deployment/glite-
> > > > > > > > > WN_sl4compat/glite-WN_sl4compat.asp Step  | apt-get install glite-WN_sl4compat
> > > > > > > > > Error | Reading Package Lists... Done
> > > > > > > > > 	Building Dependency Tree... Done
> > > > > > > > > 	Some packages could not be installed. This may mean that you have
> > > > > > > > > 	requested an impossible situation or if you are using the unstable
> > > > > > > > > 	distribution that some required packages have not yet been created
> > > > > > > > > 	or been moved out of Incoming.
> > > > > > > > > 
> > > > > > > > > 	Since you only requested a single operation it is extremely likely that
> > > > > > > > > 	the package is simply not installable and a bug report against
> > > > > > > > > 	that package should be filed.
> > > > > > > > > 	The following information may help to resolve the situation:
> > > > > > > > > 
> > > > > > > > > 	The following packages have unmet dependencies:
> > > > > > > > > 	  glite-WN_sl4compat: Depends: glite-wn-config (>= 2.3.12-0) but it 
> > > > > > > > > is not 	going to be installed                      Depends: edg-
> > > > > > > > > mkgridmap but it is not going to be installed                      
> > > > > > > > > Depends: edg-mkgridmap-conf but it is not going to be installed
> > > > > > > > > 
> > > > > > > > > I tryied several other ways how to force apt to install glite-WN, but
> > > > > > > > > unsuccessfully (I was successful only in one case, but I was not 
> > > > > > > > > able to repeat it on other machines and I'm not sure if it is 100% 
> > > > > > > > > OK). I really dont know what to do next, could anybody help me ? (I 
> > > > > > > > > spent lifetime to solve this but still remaining stuck on dependency 
> > > > > > > > > problem I cannot solve)
> > > > > > > > > 
> > > > > > > > >  Vladimir
> > > > > > > > ------- End of Original Message -------
> > > > > > > > 
> > > > > > > 
> > > > > > 
> > > > > 
> > > > -- 
> > > > 
> > > 
> > -- 
> > pozdrav
> > Acko
> > 
> > -----
> > Branimir Ackovic
> > AEGIS01-PHY-SCL Grid site Manager
> > E-mail: [log in to unmask]
> > Web: http://scl.phy.bg.ac.yu/
> > 
> > Phone: +381 11 3160260, Ext. 152
> > Fax: +381 11 3162190
> > 
> > Scientific Computing Laboratory
> > Institute of Physics, Belgrade
> > Serbia
> > -----
> > 
> 
-- 
pozdrav
Acko

-----
Branimir Ackovic
AEGIS01-PHY-SCL Grid site Manager
E-mail: [log in to unmask]
Web: http://scl.phy.bg.ac.yu/

Phone: +381 11 3160260, Ext. 152
Fax: +381 11 3162190

Scientific Computing Laboratory
Institute of Physics, Belgrade
Serbia
-----

Top of Message | Previous Page | Permalink

JiscMail Tools


RSS Feeds and Sharing


Advanced Options


Archives

March 2020
February 2020
January 2020
November 2019
October 2019
September 2019
August 2019
July 2019
June 2019
May 2019
March 2019
February 2019
January 2019
December 2018
November 2018
October 2018
September 2018
August 2018
July 2018
June 2018
May 2018
April 2018
February 2018
January 2018
November 2017
October 2017
September 2017
July 2017
June 2017
May 2017
March 2017
February 2017
January 2017
December 2016
November 2016
October 2016
September 2016
August 2016
July 2016
June 2016
May 2016
April 2016
March 2016
February 2016
January 2016
December 2015
November 2015
October 2015
September 2015
August 2015
July 2015
June 2015
May 2015
April 2015
March 2015
February 2015
January 2015
December 2014
November 2014
October 2014
September 2014
August 2014
July 2014
June 2014
May 2014
April 2014
March 2014
February 2014
January 2014
December 2013
November 2013
October 2013
September 2013
August 2013
July 2013
June 2013
May 2013
April 2013
March 2013
February 2013
January 2013
December 2012
November 2012
October 2012
September 2012
August 2012
July 2012
June 2012
May 2012
April 2012
March 2012
February 2012
January 2012
December 2011
November 2011
October 2011
September 2011
August 2011
July 2011
June 2011
May 2011
April 2011
March 2011
February 2011
January 2011
December 2010
November 2010
October 2010
September 2010
August 2010
July 2010
June 2010
May 2010
April 2010
March 2010
February 2010
January 2010
December 2009
November 2009
October 2009
September 2009
August 2009
July 2009
June 2009
May 2009
April 2009
March 2009
February 2009
January 2009
December 2008
November 2008
October 2008
September 2008
August 2008
July 2008
June 2008
May 2008
April 2008
March 2008
February 2008
January 2008
December 2007
November 2007
October 2007
September 2007
August 2007
July 2007
June 2007
May 2007
April 2007
March 2007
February 2007
January 2007
2006
2005
2004
2003


JiscMail is a Jisc service.

View our service policies at https://www.jiscmail.ac.uk/policyandsecurity/ and Jisc's privacy policy at https://www.jisc.ac.uk/website/privacy-notice

Secured by F-Secure Anti-Virus CataList Email List Search Powered by the LISTSERV Email List Manager